Tor relay on Raspberry Pi 4 with Ubuntu 21.10 hanging after couple of hours

I started recently running a relay in our office network on Raspberry Pi 4 with 4 GB RAM and Ubuntu 21.10 as OS. The setup worked well and the node began it’s operation. After a couple of hours the tor operation stops and I am not able anymore to login via SSH.
Only a reboot is helping.

Do you have any ideas what I’m doing wrong?

I am having the same problem, but on a Linux VPS. After a few hours, complete loss of network connectivity.

try install other ubuntu version

What does the syslog and/or monitoring have to say about it?

I am running Ubuntu 20.04 LTS on most of my servers, both VPS and dedicated. Crashes of Tor are rare, complete lock-ups virtually never happen.

I exactly have your hardware and using the same os, I don’t have this problem,only non stop disconnect about 20-30 days, it makes me crazy.

maybe you can use my torrc settings to try.

Now it is running fine since about 30 hours and I can connect as well.

The only difference to my previous setup is, that I also installed the package tor-arm too. It was missing, but I guess this should be essential on a Raspberry Pi as it is based on an ARM SoC, or?
I don’t know why it worked for a several hours without the arm package.

I think the tor-arm package is nyx, which was named arm once. Nyx isn’t essential (but it might be nice to have).

Edit: Yes, on new enough debian versions it just pulls in nyx: Debian -- Details of package tor-arm in bullseye, in older releases it is it’s own package of arm: Debian -- Details of package tor-arm in stretch

Right, the tor-arm package is unrelated to your issues here (i.e. installing it didn’t fix whatever your original issue was).

If you were talking about longer run times before the system freezes up, I would wonder if you’re running out of memory, and linux’s out-of-memory killer is killing random things like ssh. But in just a few hours this isn’t a good match for what might have gone wrong (and anyway 4 gigs should be enough).

Since Tor is just a user space program, and your system is freezing up, this is a bigger problem than just Tor. Faulty hardware might be one possibility. The idea above to look at your syslog lines is a good one.


That’s rare. It’s running now tor for more than three days without any problems.

Nyx was installed before.

So I am closing this, even when I don’t know what was the right solution.