Using Onion Service to connect to my server remotely

Last year, when I 1st thought about setting up an Onion Services website, I came across a post where the author said they used Hidden Services on all his home computers so that he could connect remotely to them like a VPN. Now that I’m actively setting up Onion Services I am thinking this additional usage would be handy. Unfortunately I can find neither the original post nor any other reference to this alleged setup. Is such a thing possible and if so how?
My systems all use Linux Mint 19-21, I usually connect through Nord VPN. I’m running AnyDesk to connect to my server on my network, and NoMachine to connect to my Oracle Virtual Boxes also only from my network.

I’m wondering if the person who posted was using their computer as a file server and not accessing the desktop.
I’m using Apache, and by eliminating the index page, I get a file list of the http folder and can navigate from there. I’m able to access hidden files and folders provided I know the names and even created a short cut to a mounted hard drive from another computer (through fstab using cifs on startup).
I’m still hoping to actually vpn into my desktop. I know there is a way to access a running monerod on an onion server, so I’ll keep looking

You can try using NoMachine with Tor too:
Put HiddenServicePort 4000 on server.
Then set client to connect to .onion address with socks proxy set in NoMachine
client to address and 9050 port.

That sounds like an excellent solution, I’ll give it a try right after I finish fighting with Apache about serving up a 2nd onion site. It never fails the folks writing up instructions know what they are doing and leave off a step or two that is vital because it is so obvious.

Ok I finally got around to solving my other problem and am back to working on this. I’m guessing I misunderstood one of the settings or where to set it. I’m attaching screenshots to show how I set it up. It’s not working and rather than waste a week messing around I decided to just ask directions.

You put proxy address to the wrong place.
This is how it should be done:

1 Like

Thanks works like a charm. I knew I just had things in the wrong place. I’m using it now to post this reply.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.