Unable to find IPv4 address for ORPort


Tried to figure out by myself but failed. Other topics here not helped.

Node: 771E0824EF82D85E04D80116554111E37F7EB796
ip: dynamic (random on reconnect, but reachable from internet) – can’t be pinned in config
Seems I can reach OR and DIR ports with netcat from remote server.
Tried to find in source code(GitHub - torproject/tor: unofficial git repo -- report bugs/issues/pull requests on https://gitlab.torproject.org/ --) error message but not found

It seems my ISP done something naughty (but not 100% sure)

PS It could be really cool if I could get more information about the error, like remote ip or something

Apparently your relay is hosted in Russia. So, probably you should check if your ISP is blocking Tor.

1 Like

Bootstrapped 100% (done): Done in journalctl
and network seems works fine, checked it with
curl -x ‘socks5://’ --output filetxt ‘http://icanhazip.com

Eventually it started working after 3 days without any changes from my side. :roll_eyes:

As a plan B: it seems you can write in config not only ip, you can put a dns name or ddns (which can be configured in router or host).

never ever use github web ui to find something in source code. do not repeat my mistake :sweat_smile:

This topic was automatically closed 5 hours after the last reply. New replies are no longer allowed.