UI broke after updating

Just updated to the latest version, the UI broke, hard to explain, so here’s a screenshot.

1 Like

Can you check if this is the issue?

Thank you for your help with this.

The screenshot I posted is literally the entire browser - so in a way yes, those things listed in that GitLab issue are things I’m missing. But there is also no location bar, status bar, main browser window! etc.

I have “restore previous session” set, which are the tabs that are being displayed in that screenshot. Because of this, I want to avoid reinstalling.

Let me know how else I can help with this issue.

Thanks again!

Could you share what’s your Operating System and version?

Debian 10
11.0 (based on Mozilla Firefox 91.3.0esr) (64-bit)

I’m using Debian 10 too and it’s working fine. Could you create a new user, install Tor Browser 11 following the official instructions, and check if the issue persist?

Thanks for your help with this.

It works (works better) w/ a new installation.

Coincidentally, i have the “Always use private browsing mode” turned off, I’m wondering if it is related to this issue:

I also have this setting turned on: “Remember browsing and download history”, to save my tabs.

I noticed that I can use a keyboard shortcut to open a new private window, and the browser at least becomes usable, but it looks/acts abnormal - like icons and other things are out of place at certain times (kinda hard to explain again!).

On macOS I encountered a similar browser chrome issue, also after disabling “Always use private browsing mode”. Luckily I got to keep all the chrome elements but it’s difficult to use.

The address bar, tabs, and toolbar buttons become displaced. The toolbar appears to be larger in height, affecting the viewport height. The toolbar also expands and shrinks depending on the number of address bar suggestions.

The issue persists after deleting Tor Browser, re-installing, and disabling the “private browsing mode” option again.

Looks like many more people have encountered the issue.

Quite relieved that it isn’t just me.

Much love to the dev team.


Does the UI get fix when you turn on "Always use private browsing mode” ?

I have the same issue on Windows.
I didn’t try to do a fresh install yet but that would fix things? or there is an official word about it?

Joining with the Kubuntu 18.04 x64 and would like to note that the problem firstly appeared in the Alpha channel. The latest version that works well for me is 11.0a9, so the roots of the bug may be traced from the version 11.0a10.

Disabling “Always use private browsing mode” seems to be what is causing this issue, a fix has been made and will be available in the next Alpha and Stable, until then you must have it enabled to use TB 11.

This is the relevant issue: Browser chrome breaks when private browsing mode is turned off (#40690) · Issues · The Tor Project / Applications / Tor Browser · GitLab


Thanks but someone said that there is even an issue regarding NoScript that wont prevent the disabling of the JS. I don’t remember where I read this but this issue is far more worrying

I’ve said it multiple places. As far as I know it the bug only affects Windows. For this reason the windows download on Tor Project | Download has been reverted to 10.5.10.


Hello I also encountered the issue with Ubuntu 20.04.3 LTS

Solved by ticking “Always use private browsing mode”

Screenshots :

It is not very convenient for me, and hope it will be fixed, but at least I know there is a workaround :slight_smile:


Fixed for me in 11.0.1 (at least for the most obvious, I didn’t checked everything carefully yet).


Thanks for the update!

I just updated here as well, and everything looks good! I also haven’t checked everything thoroughly yet either.

Thanks everyone who helped with this! :tada: