Trouble downloading newest version of Tor in Debian bookworm

I’m not sure if I’m posting in the right spot, I wasn’t able to post in the tor-relays section.

I have added the correct package repository and gpg key for tor following the official tutorial.

Here is my /etc/apt/sources.list.d/tor.list file:

deb     [signed-by=/usr/share/keyrings/tor-archive-keyring.gpg] bookworm main
deb-src [signed-by=/usr/share/keyrings/tor-archive-keyring.gpg] bookworm main

Doing apt update, I can see that the packages are being fetched correctly with no errors.
But installing tor still install the Debian package version. I also tried disabling other repos like these:

Hit:1 bookworm InRelease
Get:2 bookworm-security InRelease [48.0 kB]
Get:3 bookworm-updates InRelease [55.4 kB]
Get:4 bookworm InRelease [23.6 kB]

in the apt configs but it still would not install tor from
I thought that the problem could maybe reside in the fact that tor was already installed from a debian repo before I added the toproject sources.

At the moment, I was able to use:

deb     [signed-by=/usr/share/keyrings/tor-archive-keyring.gpg] tor-experimental-bookworm main
deb-src [signed-by=/usr/share/keyrings/tor-archive-keyring.gpg] tor-experimental-bookworm main

and install the experimental version and get a relay running, but it’s not optimal.

OS: Debian 1:6.1.73-1+rpt1 (2024-01-25) aarch64
On a Raspberry Pi Zero 2W

Thanks in advance!


I wanted to clarify a thing or two.

I manage to download and run Tor version

If I remove the Experimental repository, here is what I get:

apt update output:

Hit:1 bookworm InRelease
Hit:2 bookworm-security InRelease
Hit:3 bookworm-updates InRelease
Hit:4 bookworm InRelease
Hit:5 bookworm InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository ' bookworm InRelease' doesn't support architecture 'armhf'

The 2 upgradable packages are not tor

Also, I tried doing this in /etc/apt/preferences.d/my-preferences

Package: *
Pin: origin
Pin-Priority: 1001

Still no luck :confused:

I tried removing debian repos completely or calling for the specific version of tor that I want, but that doesn’t seem to work either.

1 Like

Same issue on my own Raspberry Pi