Tor relay not working "your server has not managed reachability for...."


Im trying since weeks to get my tor relay working.
i setted up on termux and on a armbian system.
both have the same issue:

Se7 15:28:04.000 [warn] Your server has not managed to confirm reachability for its ORPort(s) at and [::9829:e5ff:xxxx:c742]:9001

im using a tplink router with sim card (mobile internet)
dont know if thats the problem. my external ip i think is not static but it stays the same till i restart the router.

so what did i do already:
im configured the port forwarding (normal)
im configured the port forwarding 9001 to 443
i setted the orport to the ip of my device
i bind the mac adresses and ip adresses
i tried with nolisten and noadvertise
i asked 100 times chatgpt
and much more i even not remember

port forwarding at my tplink router should work right so far.

what i didn’t done so far:

  • asked my service provider if these ports are open (but i can connect to tor without any problems)
  • tried another router

my current torrc file:
ORPort 443
nickname + contactinfo
DirPort 9030

im not a pro in this area but i m able and wanna to learn.

could someone please give me some inputs?

thanks and have a nice day

This is a connectivity issue. The ports you set are unreachable from the outside for whatever reason. You state the config has an ORport of 443, yet that is not what the warning is saying. I’d keep it as simple as possible. Don’t get creative with port forwarding. I’d also advise to not set IPv6 for now.

1 Like

yah, first i was trying “default” torrc config with 9001, but cause its not working i done some experiments with the port settings

sorry, i dont got that the issue does not march the torrc file i sent. It was from my last “experiment”

Sep 23 21:51:12.000 [warn] Your server has not managed to confirm reachability for its ORPort(s) at Relays do not publish descriptors until their ORPort and DirPort are reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.

thats a bew one with “default” torrc

Carrier-grade NAT - Wikipedia maybe?



I’m not sure about it but I guess when you’re connected in cellular network, 4 or 5G, the proxy where your router is connected is already “natted”, so in theory the port forwarding rule should be created there, but of course we can’t because the cellular proxy is managed by the ISP.

In summary, you have a LAN behind your router as usual, which his on a vLAN, like 10.x.x.x from your ISP, so your router doesn’t “manage” the incoming traffic which the destination is the WAN IP. If you have an Android phone with a SIM card you can see the LAN IP that you have from your ISP behind the 5G proxy on the details (maybe on iOS too but I don’t know where we can see it).

Maybe wait a confirmation but I guess there is something like that in cellular network

Thanks for the answer.
I will call my provider this monday.

will update when im done and tried again.
im in holidays the next to weeks but i think i can do this before i drive away.

Booa thank you guys really, id thaught it will took the whole year to set uo this relay. :slight_smile: