Tor failed because the service did not take the steps required by its unit configuration

Hello, my bridge worked on Linux Ubuntu 20, but now at i see “no resources for the given id”

And “systemctl status tor” returned “failed because the service did not take the steps required by its unit configuration.”

After “systemctl stop tor”, waiting until processes disappear and starting, i see:

     Loaded: loaded (/lib/systemd/system/tor.service; disabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: protocol) since Sun 2022-02-06 timehere; 1s ago
    Process: 845368 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
   Main PID: 845368 (code=exited, status=0/SUCCESS)

Tor log file ends by:

[notice] Self-testing indicates your ORPort myip:myport is reachable from the outside. Excellent. Publishing server descriptor.
[notice] Interrupt: we have stopped accepting new connections, and will shut down in 30 seconds. Interrupt again to exit now.
[notice] Delaying directory fetches: We are hibernating or shutting down.

journalctl -u tor

Starting Anonymizing overlay network for TCP (multi-instance-master)...
tor.service: Failed with result 'protocol'.
Failed to start Anonymizing overlay network for TCP (multi-instance-master).
tor.service: Scheduled restart job ...

tor --version
Tor version

Start the daemon via su debian-tor -c tor to get the full output. Otherwise you can find more logs in the configured directory or via journalctl -(f)u tor.
I just assume that the tor user on Ubuntu is also called debian-tor.

Please also clarify which version you are using. Please do not use the tor version from the ubuntu-repo. Why and how I can enable Tor Package Repository in Debian? | Tor Project | Support

I have updated my initial post with some details You have mentioned.
su debian-tor -c tor
shows no output

# groups
root debian-tor
# tor
[notice] Tor 
[warn] /var/lib/tor/MyCustomDir is not owned by this user (root, 0) but by debian-tor (113). Perhaps you are running Tor as the wrong user?
[warn] Failed to parse/validate config: Failed to configure rendezvous options. See logs for details.
[err] Reading config failed--see warnings above.

any other ideas what to try? or i should backup torrc and must install from torproject instead of ubuntu repo? (i wish i do not need)

Try su -c tor - debian-tor instead

it return no output, journalctl -xeu tor still shows messages like:

-- The unit tor.service has entered the 'failed' state with result 'protocol'.
systemd[1]: Failed to start Anonymizing overlay network for TCP (multi-instance-master).
-- Subject: A start job for unit tor.service has failed

From which repository did yout get your tor version? The torproject repo should be at at the moment and ubuntu 20 is at

The tor.service under debian and ubuntu is kind of a wrapper. If you want to get meaningful logs and you have not changed the default context of your tor installation try journalctl -u tor@default.

This seems like a problem with the hidden service you are running. Maybe try to remove the parts of your torrc that are related to this and start debugging from there, if your main goal is to run a bridge.

Sorry for the confusion.

$ sudo apt show tor         
Package: tor
APT-Sources: focal/main amd64 Packages

tor --version shows
reason is that i have not upgraded packages for some time, so i did now: sudo apt upgrade
systemctl status tor
now it shows:
Active: active (exited)
which seems good and yours mentioned “journalctl -u tor@default
shows “Started Anonymizing overlay network for TCP.

when i systemctl restart tor, i can see:

Your Tor bridge's hashed identity key  fingerprint is 'Mynicknamehere stringhere'
[notice] Your Tor server's identity key ed25519 fingerprint is 'Mynicknamehere stringhere'
[notice] You can check the status of your bridge relay at

but on that URL is “no resources for the given id”, someone mentioned that “After ~3 hours you will be able to find your bridge on Metrics portal.” so it is a bit confusing that the tor is announcing the URL “You can check the status of your bridge relay” yet it does not work (“no resources” message) or does not explain when it may start working.

I have the same problem with a bridge i run myself. Check if you can find it at Relay Search. You can use the nickname or the hashed fingerprint to find it.

1 Like

weird Tor daemon provided URL fails as mentined, yet Relay search found it and URL Relay Search shows:
Transport protocols
after like 10 hours the same “no resources” message at yet mentioned metrics page “Bridge distribution mechanism” changed from None to Moat (“Tor Browser, allowing users to request bridges from inside their Tor Browser settings”).