Tor Core install fails on Linux Mint 21/Ubuntu "jammy"

It appears that the recently-released Linux Mint 21 no longer has libssl1.1:

root@bullwinkle:/home/dan# apt install tor
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tor : Depends: libssl1.1 (>= 1.1.1) but it is not installable
       Recommends: tor-geoipdb but it is not going to be installed
       Recommends: torsocks but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@bullwinkle:/home/dan# apt search libssl
p   libssl-dev                      - Secure Sockets Layer toolkit - development
p   libssl-dev:i386                 - Secure Sockets Layer toolkit - development
p   libssl-doc                      - Secure Sockets Layer toolkit - development
v   libssl-doc:i386                 -                                           
p   libssl-ocaml                    - OCaml bindings for OpenSSL (runtime)      
v   libssl-ocaml-aifn8              -                                           
p   libssl-ocaml-dev                - OCaml bindings for OpenSSL                
v   libssl-ocaml-dev-aifn8          -                                           
p   libssl-utils-clojure            - library for SSL certificate management on 
i   libssl3                         - Secure Sockets Layer toolkit - shared libr
p   libssl3:i386                    - Secure Sockets Layer toolkit - shared libr

Is anyone working on this update for Tor?

I notice that the Ubuntu repository has Tor that uses libssl3. But the Tor package is an older release. And, it’s a flatpack.

If your trying to install from repo, you’ll need to download and compile the openssl 1.1.1 from them, but tor also uses the newer version of openssl3.0 as well.
I ran into this exact issue not but maybe a week or so ago, and there are a few different 1.1.1 versions, 1.1.1j and 1.1.1i to name just a few. Some work, some don’t.
You can get the tarball source for both the 1.1.1i and 3.0.5 that work with tor, id suggest compiling both. Then try tor again

My method for solving was to compile tor as a static build, and I compiled libevent, both 1.1.1 and 3.0.5 of openssl, and zlib by hand and linked them during the config stage. Though im sure this sort of specificity won’t be necessary, try compiling 1.1.1i first, and see if that helps.

Thanks for the info. I’m not a compile-from-source kinda guy, though. More of a system administrator/installer rather than developer. So I have almost no experience putting those pieces of source code together.

I went ahead and installed the older flatpack. Oddly, it does use the newer openssl.

No worries, its easy to forget sometimes just how jaded I am lol here, give this a whirl:
copy paste this into your terminal


sudo dpkg -i libssl1.1_1.1.1f-1ubuntu2_amd64.deb

Then do an apt and apt-get cleanup, and reinstall the binaries


This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.