TOR connects, but will never actually reach a page, or if it does will not allow multiple tabs

Hi all, hoping someone may be able to help. I’ve tried to reinstall multiple times with very little luck.
I’m able to connect to the Tor network with no issue usually, but once I do so everything seems to break down.

Either one of two things happens

  1. The sites I attempt to reach (including regular internet sites) will take an extremely long time to load, or more likely, never load, just be stuck on connecting. I’ve left it for more than 30 minutes doing so.

  2. If it DOES load, it is unable to use multiple tabs, the other tabs don’t even begin a connection process.

I’ve used bridges and without, I’ve used different security settings, and have also manipulated both firewall and antivirus with little help. My internet speed itself is not an issue, so wondering if there is something specific that may be causing this.

It’s been occurring for about two months at this point

  • Windows 10
  • Latest Stable Version of Tor
  • multiple Security Level

I doubt that it will help, but anyway:

  1. To rule out possibilities of problems happening because of misconfigured operating system, it is possible to install Tor inside virtual machine (VirtualBox for example). It is also good to use different OS inside VM - Ubuntu for example.
  2. You say that you used bridges, but did you tried to select snowflake bridge? It uses different protocol and it may be important for solving connection problem.

Windows is too bad, why not change OS to unix based system ?

Are there any messages in the log?

about:preferences#connection → View the Tor logs