Sites do not work after transfer to another server. Details: 0xF2 - dating error

I decided to transfer the tor sites to another server, I transfer files, write a new path, launch the tor browser (successfully), and when I open the site, it says “Connection to the onion site is broken. Details: 0xF2 - dating error.”
The site files were transferred exactly right. The address of the folder with the file is also correct. TK when I delete files and start Tor, it creates files there with a new generated address, which is successfully opened from other devices.
And the old file with the site does not work for some reason. Log files are not found.
What to do? Wait until something is updated somewhere on the Tor servers or what?

A error code of XF2 means that the onion site has disconnected …

Given the error message I would recommend checking whether the date and time is accurate on the server you’re setting up your onion service.


I changed the time on the old server to the correct one and now all the sites have stopped working on it (
Restarted the server, did not help, the dates are correct for the country in which the server is located, in Malaysia, time zones +8 Kualu Lumpur, currently it shows 4:35 10 February 2022
What date should be set? help me please

  1. it looks like we found a problem, due to the time on the server.
  2. Help! now other sites do not work on the old server after the time has changed there, although it was also the same.

@naem, can you share the output of date -u from your server?

As I already wrote in the next topic, Tor does not launch sites on any Linux-like systems. I have to do this with windows server 2019. I made a similar command in them.
new server:

C:\Users\Administrator>time /T
C:\Users\Administrator>TZUTIL /g
Singapore Standard Time

old server:

C:\Users\Administrator>time /T

C:\Users\Administrator>TZUTIL /g
Singapore Standard Time

Sorry, I did not note that you’re running Windows. I think [System.DateTime]::UtcNow in powershell is the equivalent of date -u on Windows.

What error message are you seeing now while accessing the onion sites hosted on that server?

1 Like

Details: 0xF0 - The requested onion resource descriptor was not found in the hash. The service is not available to the client.
Onion sites on the old and new server. Regular sites hosted on the old server work. so it’s not because of programs like apache and so on…

PS C:\Users\Administrator>  [System.DateTime]::UtcNow

9 february 2022 г. 21:23:08

already rebooted the server completely. did not help please help, at least morally.

Can you check whether your tor is up and running since the reboot? :slight_smile:

1 Like

Tor browser works fine on both servers. Not my sites open.
I got up in the morning, now the sites on the NEW server are working, after restarting the server they also work)))
And they still don’t work on the old one, after yesterday I edited the time on it, although it seems to be correct ((What should I do?

UPD> I just rebooted the old server, the tor sites still don’t work, the regular ones do. Tor starts successfully. The time is the same as on the new server, where everything worked.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

Hooray. now tor sites are working on the old server. I still did not understand what happened, I just waited for almost a day and they themselves earned it. I completely rebooted the server, it also worked. Thanks to everyone who responded)))

1 Like