Relay keeps appearing as offline

I’ve been running a relay but a problem I’ve found is that tor metrics is constantly showing it as offline.
Nickname: btorbox
Fingerprint: 460C699FA1BE8FA7404EE3264B0E3099660F29DB
This means that it isn’t being included in any consensuses and it’s making the relay get barely any traffic.
I’ve heard that something similar about how tor is getting ddossed and that might be why.
Does anyone know if this might be an issue on my end and how I can fix it?

  1. check if your ports on firewall a proper open
  2. check if you port on firewall is pointing to correctly ip and port machine running tor
  3. check if your computer port is allowed on firewall
  4. check your config file is according with tor config relay on website

@red0bear Instead of guessing you needed just to try connecting to this relay.

I tried and it works fine for me:

Nov 22 11:16:41.000 [notice] Bootstrapped 0% (starting): Starting
Nov 22 11:16:41.000 [notice] Starting with guard context "bridges"
Nov 22 11:16:41.000 [notice] Delaying directory fetches: No running bridges
Nov 22 11:16:42.000 [notice] Bootstrapped 5% (conn): Connecting to a relay
Nov 22 11:16:42.000 [notice] Bootstrapped 10% (conn_done): Connected to a relay
Nov 22 11:16:42.000 [notice] Bootstrapped 14% (handshake): Handshaking with a relay
Nov 22 11:16:43.000 [notice] Bootstrapped 15% (handshake_done): Handshake with a relay done
Nov 22 11:16:43.000 [notice] Bootstrapped 20% (onehop_create): Establishing an encrypted directory connection
Nov 22 11:16:43.000 [notice] Bootstrapped 25% (requesting_status): Asking for networkstatus consensus
Nov 22 11:16:44.000 [notice] new bridge descriptor 'btorbox' (fresh): $460C699FA1BE8FA7404EE3264B0E3099660F29DB~btorbox [l5ZWHLQLJw7SUa2qgvv5nA7N+zSFzrhyC2l4jsBRKyo] at
Nov 22 11:16:44.000 [notice] Bootstrapped 30% (loading_status): Loading networkstatus consensus
Nov 22 11:16:46.000 [notice] I learned some more directory information, but not enough to build a circuit: We have no usable consensus.
Nov 22 11:16:46.000 [notice] Bootstrapped 40% (loading_keys): Loading authority key certs
Nov 22 11:16:46.000 [notice] The current consensus has no exit nodes. Tor can only build internal paths, such as paths to onion services.
Nov 22 11:16:46.000 [notice] Bootstrapped 45% (requesting_descriptors): Asking for relay descriptors
Nov 22 11:16:46.000 [notice] I learned some more directory information, but not enough to build a circuit: We need more microdescriptors: we have 0/6096, and can only build 0% of likely paths. (We have 100% of guards bw, 0% of midpoint bw, and 0% of end bw (no exits in consensus, using mid) = 0% of path bw.)
Nov 22 11:16:47.000 [notice] Bootstrapped 50% (loading_descriptors): Loading relay descriptors
Nov 22 11:16:47.000 [notice] The current consensus contains exit nodes. Tor can build exit and internal paths.
Nov 22 11:16:50.000 [notice] Bootstrapped 56% (loading_descriptors): Loading relay descriptors
Nov 22 11:16:50.000 [notice] Bootstrapped 63% (loading_descriptors): Loading relay descriptors
Nov 22 11:16:51.000 [notice] Bootstrapped 71% (loading_descriptors): Loading relay descriptors
Nov 22 11:16:51.000 [notice] Bootstrapped 75% (enough_dirinfo): Loaded enough directory info to build circuits
Nov 22 11:16:51.000 [notice] Bootstrapped 80% (ap_conn): Connecting to a relay to build circuits
Nov 22 11:16:51.000 [notice] Bootstrapped 85% (ap_conn_done): Connected to a relay to build circuits
Nov 22 11:16:52.000 [notice] Bootstrapped 89% (ap_handshake): Finishing handshake with a relay to build circuits
Nov 22 11:16:52.000 [notice] Bootstrapped 90% (ap_handshake_done): Handshake finished with a relay to build circuits
Nov 22 11:16:52.000 [notice] Bootstrapped 95% (circuit_create): Establishing a Tor circuit
Nov 22 11:16:55.000 [notice] Bootstrapped 100% (done): Done

You may try looking at page
And try to find some patterns.
Data is available for every hour:

It may be that some authorities do not see relay at all.
Or it may be that it is not accessible at some time, but accessible at other time.
Or it may be accessible all the time, but sometimes with very low bandwidth.

Tor must work in way to anyone connect or configure it without put much effort on it. All i said is to check ways do see if not is missing.

I checked the page that you linked and noticed that it only gave the running flag on two relays. The relay did appear on all columns on the page that you linked. I also noticed that some relay’s consensus page didn’t load at all or some got flagged by the router and I had to click an ok button to go to the page. Maybe that might be a clue?

everything is there and I got the config from the website and opened the correct ports. I’ve operated this relay before and it worked so I guess I’m wondering what could possibly be different that’s making this happen.

always is about config, nothing more. may be tor , another firewall machine behind … etc … :eyes:

Right now (consensus-health-2022-11-23-00-00) 4 authorities mark it as Running and 5 marks as not Running, which means that average result is not Running.

Sorry, I don’t understand what you mean.
I’m saying that you can change date and time in consensus-health URL and look how authorities made votes about your relay in the past.

I restarted the relay and it connected to all directory authorities for a few hours before going back to how it normally is. I’ve also noticed a correlation where every authority that doesn’t give me a running flag is also one that I can’t connect to on the consensus health page.
When I tried to ping Faravahar it returned:
“From icmp_seq=2 Destination Port Unreachable”
which apparently means that it’s dropping my connection.
Would this mean that it is a config problem on my end and they blacklisted me? And if so what could be causing them to give me the running flag and then remove it?

1 Like

Nice work in searching the reasons!
One note: is not Internet address, it belongs to local network.
Something between your computer and Faravahar is blocking access.
You can use tracert (Windows) or traceroute (Linux) to see where exactly problem happens.
I think that block happens somewhere inside your ISP.
If this is the case, you may ask them to solve connections problem.
traceroute result may be used as proof of problem existence.

Yeah in my browser goes to my router settings. So it is probably my router/modem with its built in firewall probably having some kind of issue with the site. It’s an Xfinity Xfi router so I probably need to go in and check settings on the app. Might have something to do with their Advanced Security .


traceroute to (, 30 hops max, 60 byte packets
1 _gateway ( 0.845 ms 0.968 ms 1.027 ms
2 _gateway ( 1.150 ms 1.227 ms 1.353 ms


Tracing route to []
over a maximum of 30 hops:

1 10 ms 11 ms 8 ms
2 reports: Destination protocol unreachable.

May be related: