Problem with setting up an Exit Relay


I have a prepaid vps (ubuntu 20.04) laying around that I don’t have any use for so I thought I’d give back to the community and host an exit node (hosting provider is ok with it) until it expires but I’m having trouble setting it up.

I’ve used the tor relay configurator ( and filled in all the necessary details, installed the dependencies and then downloaded and ran the script from

This is the output i get when running the script :

This script will ask for your sudo password.
Updating package list...
-> OK
Installing necessary packages...
-> OK
Updating NTP...
 6 Dec 18:36:54 ntpdate[27105]: Can't adjust the time of day: Operation not permitted
sudo: /etc/init.d/tor: command not found
An error occured on the last setup step.
If you think there is a problem with this script please share information about the error and you system configuration for debugging:
Adding Torproject apt repository...
-> touch OK
-> tee1 OK
-> tee2 OK
Adding Torproject GPG key...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 49890  100 49890    0     0   221k      0 --:--:-- --:--:-- --:--:--  221k
-> OK
Updating package list...
-> OK
Installing NYX...
-> OK
Installing Tor...
-> install OK
-> chown OK
Setting Tor config...
-> OK
Downloading Exit Notice to /etc/tor/tor-exit-notice.html...
Please edit this file and replace FIXME_YOUR_EMAIL_ADDRESS with your e-mail address!
Also note that this is the US version. If you are not in the US please edit the file and remove the US-Only sections!
-> OK
Testing IPV6...
ping6: connect: Network is unreachable
Seems like your IPV6 connection is working
Could not automatically find your IPv6 address
If you know your global (!) IPv6 address you can enter it now
Please make sure that you enter it correctly and do not enter any other characters
If you want to skip manual IPv6 setup leave the line blank and just press ENTER
IPv6 support has been disabled!
If you want to enable it manually find out your IPv6 address and add this line to your /etc/tor/torrc
ORPort [YOUR_IPV6_ADDRESS]:YOUR_ORPORT (example: "ORPort [2001:123:4567:89ab::1]:9001")
or for a bridge: ServerListenAddr obfs4 [..]:YOUR_OBFS4PORT
Then run "sudo /etc/init.d/tor restart" to restart Tor
Enabling unattended upgrades...
Deferring configuration of apt-listchanges until /usr/bin/python3
and python's debconf module are available
-> install OK
-> wget OK
Don't install recommends...
-> wget OK
Reloading Tor config...
Restarting tor (via systemctl): tor.service.

=> Setup finished

Tor will now check if your ports are reachable. This may take up to 20 minutes.
Check /var/log/tor/notices.log for an entry like:
"Self-testing indicates your ORPort is reachable from the outside. Excellent."

Could not find Tor logfile.
This could indicate an error. Check syslog for error messages from Tor:
  /var/log/syslog | grep -i tor
It could also be a false positive. Wait a bit and check the log file again.
If you chose to install nyx you can check nyx to see if Tor is running.

So far so good, I then tried to monitor using nyx it tells me :

Unable to connect to tor. Are you sure it's running?

So I check if tor is runnug using “service tor status” which returns :

● tor.service - Anonymizing overlay network for TCP (multi-instance-master)
     Loaded: loaded (/lib/systemd/system/tor.service; enabled; vendor preset: e>
     Active: active (exited) since Tue 2021-12-07 19:35:56 CET; 19h ago
    Process: 2889 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
   Main PID: 2889 (code=exited, status=0/SUCCESS)

Dec 07 19:35:56 *************** systemd[1]: Starting Anonymizing overlay network>
Dec 07 19:35:56 *************** systemd[1]: Finished Anonymizing overlay network>

Interestingly there was no tor log file created and using “/var/log/syslog | grep -i tor” just makes the terminal freeze up…

Any help would be appreciated :slight_smile:

I’m not familiar with the script that produces for ubuntu target, but you might check and see if it’s using the ubuntu repos. The ubuntu repos are hit-or-miss, so if the config script is using that one, you might have better luck using the official debian one instead: Why and how I can enable Tor Package Repository in Debian? | Tor Project | Support

If that doesn’t help, maybe try creating the log file nyx expects manually or checking and making sure you have all your permissions configured correctly. For ubuntu, you might also check your AppArmor logs to look for access control issues there.

  1. Are you running this script as root (you should not, i guess)? is sudo configured correctly?
  2. imho running a script from a website is quite risky - i know it’s common today to wget -O - | bash but it still feels (and probably is) wrong…
  3. At least read the script and understand what it is doing before running it.
  4. Middle-way might be, to take configuration suggestions from the script and adapt it in your own doing

Thanks for the quick replies (and yes I was running it as root) but as it turns out the problem was me being an idiot. I didn’t realize my vps came with an already running apache which was using the ports needed for tor. Killed it and now the node is up and running. But thank you again :slight_smile: