Nyx Help: Only runs in root and says relaying is disabled


I was finally able to get my relay up and running (I believe) and I installed Nyx to keep an eye on operations.

However, I have some questions, and web searches are not really helping…

  1. I am only able to get Nyx to run in root. Following the instructions on the Nyx site, I am still unable to get it to run not as root. Any advice?

  2. In the image below, Nyx is saying “Relaying Disabled.” However, if I am reading Nyx correctly, I already have traffic routing through the relay. How does one rectify this confusing scenario?


1 Like

Could you post your torrc?

How are you authenticating with tor?


Here is the pastebin for my torrc… ## Configuration file for a typical Tor user## Last updated 9 October 2013 for - Pastebin.com

As far as how I am authenticating with tor, I followed the steps outlined in the middle/guard relay setup for Debian/Ubuntu here Tor Project | Debian/Ubuntu

I followed the steps to the letter to the best of my understanding.

1 Like

You must be in tor group.

usermod -aG debian-tor user

You don’t have a relay configured, that’s the default torrc. Next time please post without comments :sweat_smile:
grep ^[^#] /etc/tor/torrc

You are missing ORPort, Address and ExitPolicy reject *:*
tor-relay example torrc

Tor Relay Configurator


I appreciate the links. I used the Tor Relay Configurator site, and Nyx now shows I am relaying…

However, the ORPort is not reachable. I did a web search for solutions, and every solution that I have tried that people have said worked, has not worked for my for whatever reason. And despite the NOTICE-ERR saying my relay can not confirm reachability, it appears that on the connection page, I am indeed relaying, if I am reading everything correctly…

And here is my current torrc file with one of the internet’s fixes.

1 Like

I think that these lines are wrong:

ORPort 9001
ORPort 9001 NoListen

Do you have public IP address? If so, then ORPort 443 IPv4Only line should be enough. If not, the correct lines depends on your network configuration.

I have been able to get my relay up and running. I had to assign a new automatic IP address and completely redo the IP address and port in the torrc file to reflect the router IP and not the machine IP address, though I had to assign the port forwarding to the machine IP address, which is completely different than anything else.
Needless to say, I would highly recommend to redo the “how to set up a relay” section to have significantly more detail and steps moreso than it has.

But, my relay is up and running and is looking good. Thank you for everyone’s help!