New Tor Browser pops up screen with no recourse. No Browser. Nothing

I just downloaded the latest Tor Browser for Windows.
When launched it brings up a screen suggesting I should “Connect to Tor”.
The problem is, there’s no button to do so. There’s a checkbox that seems to toggle one to do so automatically. I tried this and launched the program again, but that doesn’t work.

This release appears to be a total fail.

1 Like

Hi @Dougga :slight_smile: Thanks for your question.

Please check this link which might help to solve the connection issue.

Hope this helps & feel free to reply if this is still an issue for you & welcome to the Tor Project Forum!

Give it another chance.

The first time I opened it, I too was met with something resembling that, the page kept loading; the “Connect” button never showed up.

I quit the app, trashed it and reinstalled 11.0.3. After awhile no new version came out, so I tried 11.0.4 again, and not sure why, but it worked.

Maybe it has to do with choosing to NOT connect automatically, aka Quick Start. It looks like we share that preference for now.