"Little t tor" (Package, linux) not working with bridges

Hi,
Apologies if I’m in the wrong place, because I am new.

I want to use tor with bridges, so I put my bridges into torrc and started tor with “systemctl start tor”. When I tried to use tor’s SOCKS5 proxy, it doesn’t work.

Upon closer look at tor’s logs, I found this:

May 14 20:42:16 Computer Tor[7708]: Read configuration fil
e "/etc/tor/torrc".
May 14 20:42:16 Computer Tor[7708]: Opening Socks listener
 on 127.0.0.1:9250
May 14 20:42:16 Computer Tor[7708]: Opened Socks listener 
connection (ready) on 127.0.0.1:9250
May 14 20:42:16 Computer Tor[7708]: Parsing GEOIP IPv4 
file /usr/share/tor/geoip.
May 14 20:42:16 Computer Tor[7708]: Parsing GEOIP IPv6 
file /usr/share/tor/geoip6.
May 14 20:42:16 Computer Tor[7708]: Bootstrapped 0% (st
arting): Starting
May 14 20:42:16 Computer Tor[7708]: Starting with guard
 context "bridges"
May 14 20:42:16 Computer Tor[7708]: Delaying directory 
fetches: No running bridges
May 14 20:42:16 Computer Tor[7708]: Signaled readiness 
to systemd

I think the problem is caused by the bridges.
Here is my torrc:

UseBridges 1
ClientTransportPlugin meek_lite,obfs2,obfs3,obfs4,scramblesuit exec /home/user/.local/opt/tor-browser/app/Browser/TorBrowser/Tor/PluggableTransports/lyrebird
ClientTransportPlugin snowflake exec /home/user/.local/opt/tor-browser/app/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client
ClientTransportPlugin webtunnel exec /home/user/.local/opt/tor-browser/app/Browser/TorBrowser/Tor/PluggableTransports/webtunnel-client
ClientTransportPlugin conjure exec /home/user/.local/opt/tor-browser/app/Browser/TorBrowser/Tor/PluggableTransports/conjure-client -registerURL https://registration.refraction.network/api

Bridge webtunnel <IP>:<PORT> <FINGERPRINT> url=<URL> ver=0.0.1

I have internet enabled. I used the bridge files in the Tor Browser.
Please help me, thanks!

1 Like

It is difficult to connect to the internet in China, let alone tor.

1 Like

That is sad in China, I’m glad my country doesn’t block access to the Internet.

1 Like

What’s your tor version and OS?

tor --version

When you start tor, check if tor has the right permission by running:

$ sudo dmesg

and try to find any permission errors (ie, apparmor).

Edit: Check if you have a webtunnel-client.

1 Like

Here is a guide for Debian-based distros:

  1. Download Tor expert bundle:
$ wget https://archive.torproject.org/tor-package-archive/torbrowser/13.0.15/tor-expert-bundle-linux-x86_64-13.0.15.tar.gz

(Or visit Tor Project | Download Tor for other platforms and versions.)

  1. Extract it:
$ tar -zxvf tor-expert-bundle-linux-x86_64-13.0.15.tar.gz
  1. Move lyrebird to other location:
$ sudo mv tor/pluggable_transports/lyrebird /usr/local/bin
  1. Change the file ownership:
$ sudo chown debian-tor:debian-tor /usr/local/bin/lyrebird
  1. Edit tor AppArmor profile
$ sudo gedit /etc/apparmor.d/system_tor

Include the line below inside this block and save:

  # During startup, tor (as root) tries to open various things such as
  # directories via check_private_dir().  Let it.
  /usr/local/bin/lyrebird ix,
  1. Reload the AppArmor profile:
$ sudo apparmor_parser -r /etc/apparmor.d/system_tor
  1. Edit your torrc:
UseBridges 1
ClientTransportPlugin meek_lite,obfs4,webtunnel exec /opt/lyrebird
Bridge webtunnel your-webtunnel-bridge-line
Log notice file /var/log/tor/notices.log
  1. Start tor
sudo systemctl start tor
2 Likes

It’s Arch Linux. The version of tor is 0.4.8.11. I just installed the lyrebird and the other clients to a folder (/etc/PluggableTransports).

I guess Arch is different from Debian because I do not see a system_tor in the apparmor.d folder.

1 Like

Yes, it’s different. Do you have a local folder in apparmor.d?

Note that on Arch, user is tor and not debian-tor.

Unfortunately I don’t have an Archlinux machine to test it right now, but you need to add lyrebird to your AppArmor profile.

https://wiki.archlinux.org/title/AppArmor

1 Like

I do have a local folder in apparmor.d, but there is no AppArmor profile for tor in both the local folder and the apparmor.d folder though.

note: I changed the file ownership as well like you said

1 Like

i’m exec aa-complain /etc/apparmor.d/system_tor mode.
not connect tor bridge