Launcher seems to not work

Hi, I’m trying to install tor browser in a fresh debian bookworm system. I got torbrowser-launcher via flatpak and started it, hit “Install” with all the default options. I get a window saying “Downloading Tor Browser for the first time” and under that a progress bar labelled “Downloading version check” which is stuck at 0%. I tried to change the mirror URL a couple of times, but same result each time.

General networking on this machine works fine. Also, I have used tor in other ways in the same location so I’m pretty sure it’s not a firewall or something like that.

Thanks for your help,


1 Like

You can download the Tor Browser from the Tor Project website:

After that, use these instructions to install Tor Browser on Debian:


It actually finished, after a long time in that state. I think it’s a bug with the launcher, it doesn’t update the progress bar during some parts of its life. It stared updating the progress bar once it got to downloading the browser package.

1 Like