In home connection issues when Relay is running

G’day fellow relay’ers.

I’ve been having this odd issue, when my relay is running it seems like even though its only taking a small fraction of my internet, the whole home seems to be affected and at one point the relay is running but internet is not functional through out the house. This caused me to have to turn off my relay tonight and all of my issues disappeared. Has anyone else encountered this ?
I am on Bell ISP, 3gb connection(both ways), and the relay normally uses around 3-7mb/s. I had them change out my modem 3 times now, and the issue persists, not sure if its something i can remedy. I def don’t want to mention to the ISP that i’m running a tor relay either.

Thoughts, ideas ?

Running on Fedora 37, cli only .
no IPv6
no exit.

thanks :slight_smile:

I would only assume that your modem/router does not have enough power to process so many connections quickly.

Yeah, that is quite unfortunate, had upgraded to the 3gb in order to allow more to go through. Live and learn.

1 Like

I’ve had similar issues with my own relay. Turns out the router that comes with my internet access isn’t great at handling dozens of thousands of TCP sessions. I’ve since disabled NAT in it (so another router I actually control does that part), and it’s better, but still not perfect. For some reason the ISP router still does some amount of connection tracking, but its performance depends less on that without NAT.


Thanks, wish Bell had a bridge or actually bypass but alas, they do not. I’ve tried adding the computer to the advanced DMZ which should put it on the outside of the network, we shall see if it works once traffic start picking back up.

So in case anyone is interested in this Bell modem issue.
I think the issue is that the Bell modem was thermal throttling as these Sagemcom fast 5689e (Gigahub) are passive cooling. I set a fan on the bottom of the unit pushing air through and I see the cpu spiking around 80% and falling back down to 3% with about 6k connections. Going to keep an eye on it and if it works I will likely 3d print a shroud and throw on a bigger fan to flow air through and keep the CPU cool. The issue at he moment does not seem to be with ram as only the CPU seems to be doing the wave (Usage going up and down).

More to come.

So this did not work unfortunately.
i tried lowering the amount of speed and the amount of connections unsuccessfully. Unless someone has an idea up their sleeve, I will unfortunately need to keep it offline. The bell modem, whether in advanced DMZ or PPOE still gets the CPU at 100% utilization and kills the rest of the internet in the home. Bell unfortunately does not have a proper bridge mode or that would likely fix my issues. They do not give access to the firewall portion of the modem either.

Thoughts or ideas are welcome.


What version is your Tor ?

Are you running a guard ? bridge ? do you have some configuration torcc ?

Those internet kill means you connection is begin used by Some DDos attack for some outside Ip. try limit what you share to 1 MB or lower and make some observations. Some ips as are ddos attackers and you should try block those malicious IPs.