Having problem when launching tor for the first time

Hi,

I tried to install tor browser yesterday. First, I downloaded tor-browser-windows-x86_64-portable-13.0.14.exe on tor project webpage. Then, I checked the key and make sure its right. I then installed it by running the exe.

However, there are problems when I try to launch the shortcut on desktop. I see a very brief flash on the screen and in task manager I can see tor as a background process (attached below), but nothing popped up afterwards.

I tried reinstalling tor and restarting my laptop, I tried giving ‘full control’ permission to the tor folder, I turned off all vpns and I only have windows security as the antivirus software. My username also only contains English characters (username is ‘Ryan’). I am not sure what I should do.

Thanks for your help.
Ryan

1 Like

Ensure that User Account Control is enabled, then try again. You can also try running the program as an administrator to see if that resolves the issue.

My UAC is always on. Running the program as administrator does not solve the issue (there is still brief flash of somehting like a program when I do so)

1 Like

I could not reproduce your situation on a (more or less) vanilla Windows 10… and I tried.

Just to get it straight, when you say you reinstalled, exactly what did that mean. It’s suppose to mean that you completely deleted the Tor Browser folder from the desktop and installed again. It’s supposed to install in a folder on the desktop.

Here is what I tried.
The whole thing requires no special privileges of any kind.
It’s not a Windows Firewall rule if one were there because the Tor Browser does not really go to the internet. It talks to the socks5h proxy tor.exe at 127.0.0.1:9150
Now if tor.exe was blocked by a Windows Firewall rule or anything else, the browser would still come up but make no connection to the proxy.
I found no Firefox command line option to log what it happening.
From your taskmanager clip I see tor.exe is running. Let’s get that out of the way and test it.
From a Windows command line issue this command:
curl --proxy socks5h://127.0.0.1:9150 http://ip-api.com/json/
This will tell you where your exit node is and confirm that it works.

Something is preventing the firefox.exe part of the Tor Browser from executing.

Edited 1 day later:
I also made a copy of firefox.exe in a temp folder and tried to execute. A pop-up occurs with an error.
Have you tried to look at event logs??
Have you tried to open a command prompt in the folder C:\Users\YOURNANE\Desktop\Tor Browser\Browser and type in firefox.exe?

2 Likes

Try launching Tor Browser from the command line with --verbose and post the output.

1 Like

Hi there,

When I reinstalled, I deleted all the contents from the Tor folder. However, I installed the tor folder in my d drive because my C drive is running out of storage. Will that be part of the issue?

Also, when I typed in that command in cmd, it returned this:
curl: (7) Failed to connect to 127.0.0.1 port 9150 after 2054 ms: Couldn’t connect to server
I am not sure what that means.

As for when I try to open command prompt in Tor folder and type in firefox.exe, it also generates a brief flash. I think it does the same thing when I try to lauch the browser shortcut on my desktop.
I am not sure how to use event logs to find issues. Should I be looking at Applicaiton Log?When I use ‘find’ function and try to find logs with keyword ‘tor’. I filtered out some logs that are unrelated but words and have tor in it. Is there an event code that I can use to filter out logs related to Tor?

Edit: I reinstalled again on desktop, but its still not working :frowning:

1 Like

Sorry it saids --verbose is not recognized as an internal or external command.
I opened the Tor\Tor Browser\Browser file and typed ‘firefox.exe --verbose’ , ‘–verbose firefox.exe’, and ‘–verbose’. I am not sure what the command is.

1 Like

I’m not sure about Windows, but on Linux it would be

tor-browser/start-tor-browser.desktop --verbose
1 Like

The D:drive is not an issue. I tried from a USB drive at G:. I never thought about another drive. HA! The install is portable so that means anywhere.

curl: (7) Failed to connect to 127.0.0.1 port 9150 after 2054 ms:
This tells me curl works but the tor.exe proxy is not up and listening at 127.0.0.1:9150
This command will show what TCP ports are listening when you try it again:
netstat -a -p TCP
You should see something like these among all the other connections:
TCP 127.0.0.1:9150 machinename:0 LISTENING
TCP 127.0.0.1:9150 machinename:58229 ESTABLISHED
TCP 127.0.0.1:9150 machinename:58230 ESTABLISHED
TCP 127.0.0.1:9151 machinename:0 LISTENING
TCP 127.0.0.1:9151 machinename:58221 ESTABLISHED

–verbose is not recognized as an internal or external command means exactly what it says. In any OS it’s command first then options. It saw verbose as a command

I did find debug stuff and will get back after I find it again. I did get some logs but it all seems meaningless for now but then mine works. Yesterday I looked for .log files instead of moz_log files. My boo-boo.

Edited later:
I found this:

TLDR;
You can start Tor from the command line as before:
firefox.exe -MOZ_LOG=nsHttp:5 -MOZ_LOG_FILE=nsHttp.log

You will get a number of nsHttp.xxxxx.moz_log files in that same folder
Maybe there will be a clue there somewhere.

If you don’t like that command line netstat there is a GUI tcpview from Microsoft