Google translate TTS doesn't work in TBB but work in regular firefox esr with tor proxy

System:Debian Stretch
TBB version:12.0 (based on Mozilla Firefox 102.5.0esr) (32-bit)
Security Level:Standard
Use Tor Browser input some text in then click “listen” button, result in no sound to play and prompt “Can’t playback audio. Try refreshing the page.”.
Regular Firefox 102.5.0esr with tor proxy( work correctly with .

I tested base-browser-linux32-tbb-nightly.2023.02.13_ALL.tar.xz having same problem.

This issue might be caused by the Tor Browser’s default security settings blocking the Google Translate TTS (text-to-speech) service. Here are some possible solutions you can try:

Adjust Tor Browser’s security settings:

- Click the Tor Button in the top-left corner of the browser window.
- Click "Security Settings".
- Set the security level to "Standard" or "Low".
- Reload the Google Translate page and try the TTS feature again.

Allow Google Translate TTS in NoScript:

- Click the Tor Button in the top-left corner of the browser window.
- Click "Add-ons".
- Click the "Extensions" tab.
- Find "NoScript" and click "Preferences".
- Click the "Embeddings" tab.
- Look for "" and make sure it is not blocked.
- Reload the Google Translate page and try the TTS feature again.

Use a different TTS service:

Try using a different TTS service, such as Microsoft Translator or IBM Watson. These services may work better with Tor Browser’s security settings. You can also try using a third-party TTS application or browser extension that is not blocked by Tor Browser’s security settings.

Hope this helps!

Thank you for reply, can you clear what is the “Embeddings” tab? I can’t find out it in NoScript’s preferences pages.
However NoScript say “blocked 0 items” when I use Google tanslate TTS.
In pratice to use service work with Tor Browser’s security settings is best solution for security reason but I a bit wondering why this is happen.

I apologize for the confusion. I forgot that the “Embeddings” tab may not be present in the current version of NoScript.

Regarding the issue with Google Translate TTS, it is possible that the Tor Browser’s security settings are blocking the necessary JavaScript code or audio playback features required by Google Translate TTS to function properly. The Tor Browser is designed to protect your privacy and security by blocking potentially harmful scripts and parts on web pages, which may inadvertently affect some website functionality.

For that reason, it’s also possible that Tor intentionally blocks Google Translate TTS to prevent audio fingerprinting attacks, where an attacker can identify users based on the unique audio playback characteristics of their devices.

You can still reduce the security levels, and it will maybe work. However, it’s essential to note that lowering the security level of the Tor Browser may reduce the privacy and security protections it provides. Therefore, it is recommended to use caution and only adjust the settings if absolutely necessary.

Just be careful.

1 Like

Thank you very much for so much detail informations.
Inspired by you, I solved this problem by turn dom.webaudio.enabled to True in the about:config page, dom.webaudio.enabled is True in official Firefox-ESR but False in Tor Browser due security reason.
For all peoples who want to really keeping anonymous: If the service don’t work with default security configuration of Tor Browser then it is danger thing for you and you should seek a alternative service.
This solution just for who want to cost at security to get functionality(e.g people who merely use Tor Browser as one anticensorship tool don’t care anything of anonymous).

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.