Exit Relay Port 80

So i run three nodes
one Exit on Port 443
One Middle/Guard on Port 443

and another Exit Relay on Port 80

Well over the last month or so my Relay on port 80 has been suddenly dropping out

and all i did was copy the tor file from the exit relay that i run on port 443 to the one running on port 80
all i did was change the port from port 443 to port 80

Well suddenly the one on port 80 has been dropping out
nothing in the logs show a DDoS attack or showing any signs of errors

what could the issue be where the Tor Metric site is unable to see the server.

i have the proper ports open


nyx shows my relay still communicating with the Tor network.
idk how to fix this as my other two relays are not having any issues JUST the one port 80

I don’t see any alarming things in your node stats. Bandwidth can be tricky, and it fluctuates naturally. In my experience most of the time it’s the server connection itself, although if your CPU is maxing out that will hurt it as well (but doubt that with the amount traffic right now).

yeah it’s odd that this one server is dropping out vs my other two servers
i have a support ticket open on the hosting side of things.

but yeah all i did was copy the torrc file from my 443 relay to the port 80 relay
and just changed the port number from 443 to 80

and fired the relay up and it worked. when i first built it.