"CreateProcessA() failed: The system cannot find the file specified." when I'm trying to use obfs4proxy

When I try to use a obfs4proxy with Tor expert bundle, it shows CreateProcessA() failed: The system cannot find the file specified. I tried to launch is as an admin, no luck. Replaced it with the one that comes with Tor browser, still nothing, which is strange. Also checked the permissions of the folder, all good there. What could cause this to show an error? Thanks! I’m using Windows 11 22621.1485 and Tor

Most likely, you have wrong path to obfs4proxy binary in your torrc file.
Here is example which works for me:

DataDirectory c:\tor\___expert\tor
GeoIPFile c:\tor\___expert\data\geoip
GeoIPv6File c:\tor\___expert\data\geoip6
UseBridges 1

SocksPort 9050

ClientTransportPlugin obfs4 exec pluggable_transports\obfs4proxy
Bridge obfs4 17E8018A2FEA561E2F9766C5CD63FF74C33A16D6 cert=U2vIrD4IHO+Ji5fUTREmMnk9UcU8jhh2/eAUhtwxf4tw0abqeqJMk4znttbMpKVBgKvjIg iat-mode=0

(bridge address is already public so I think publishing it again will not hurt)

I tested tor-expert-bundle-12.0.4-windows-x86_64.tar.gz and tor-expert-bundle-12.0.4-windows-i686.tar.gz with Windows 7 SP1 x64.

Hmmm, last time when I just pasted path to the obfs4proxy, it was showing the same error, but now it works, thanks!

1 Like