Choppy video playback with Tor Browser Flatpak

Hi everyone,

I am experiencing a really annoying issue with the Tor Browser flatpak version. On some websites, playing a video is very choppy and not really watchable. Others are just fine. The problem does not exist on Firefox flatpak, so I guess it is a Tor browser issue and dependencies like openh264 shouldn’t be the problem.

I wanted to test it with the non-flatpak, (both the RPM version and the official version from the website) but there the videos don’t even load at all, even with all the codecs installed. It used to work on Arch Linux.

I am currently using Fedora Linux 36, but this bug is not limited to Fedora.
My currently installed tor browser version is 11.0.14.
Security level is set to safer, but the problem persists on standard security setting.

Here is an example video:
It plays just fine in Firefox flatpak, but with Tor Browser flatpak it is very choppy.

I’ve also had the same problem with just downloading a random YouTube video and playing the downloaded file with tor browser.
The tor log also doesn’t show anything useful at all. (I just went to settings, scrolled down and clicked the “View Logs…” button, hopefully those are the tor logs)

Hopefully, someone can help with that and have an awesome day :wink:


I want to further add to this that after i did a fresh install of nixOS with no firefox-bin package, only Tor-Browser from flatpak. I was noticing that videos on youtube worked fine btw.

However videos on the invidious instance for yt only worked with dropping tons of frames. I solved that by installing:

flatpak install flathub org.freedesktop.Platform.ffmpeg-full/x86_64/21.08

But, videos for some websites ( or still drop frames.

I know great ppl. The Best. Outstanding ppl, at flatpak. They dont seem to know any other solution rn and why it doesnt work.

Pls Mr.Micah look into this issue. Thx.


forget what i said before. ffmpeg v 21.08 is broken… u need to get 20.08 and that will completly solve your issue. (or even go back a version more if it still wont work.)

1 Like

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

Hi there,

A couple days ago I made a post because I had a problem with video playback in tor browser. A solution was posted, and the issue closed automatically, but the solution never fixed my problem. So here I am again. Any ideas?

And btw I noticed that even if I don’t have ffmpeg-full installed videos still play and are still choppy, so does it even have anything to do with ffmpeg-full?

I have had the same issue with Tor Browser Launcher from Flathub on both Fedora 35 and 36. I didn’t find a solution. But if you use the packaged version from it should work without issues (at least it does for me). I don’t know why the videos did not load for you using the official Tor Browser bundle. Perhaps it was a network issue at the time, or you got unlucky and got served an especially slow guard. In any case, I suggest you try a new download from Tor Project | Download
Make sure it’s a clean extract of the new tar file you download, so that previous config files are not kept.

I downloaded and ran both the stable and the alpha version on Fedora 36, and video playback on both Youtube and Invidious are now fine. Your example video also plays fine.

I assume by “RPM version” you mean torbrowser-launcher from the Fedora repositories. I’d say, just ignore that and go with the official download from

But if you for some reason would like to stick with the Flathub version, I can’t help you.

Yeah, I tried it again with the official package. It tells me that tor browser can’t open this file and asks me to download it. All codecs should be installed. I will try it on a live USB soon, maybe it is just some codec.

Because it’s a tar archive that needs to be extracted…

But why does it work in the Flatpak version then?

What is “it”? The video link you posted in the first post? If so, try playing a video from any other site that you had issues with.
When you wrote “Yeah, I tried it again with the official package. It tells me that tor browser can’t open this file and asks me to download it.” I thought you were talking about trying to download Tor Browser from

Oh, yes sorry that was on me. I meant the official tor browser asks me to download the video that I posted instead of playing it.

I did try some other websites, and it’s the same almost everywhere, although there are some exceptions. Some websites just tell me that this format is not supported by my browser and the video refuses to play.

OK, then possibly some codec issue on your system. Do you have rpmfusion repositories enabled? And please try other streaming videos. For example, Invidious playback is choppy for me on the Flathub version, but works fine in the native version from torprojectdotorg: FIFA 22 - TOP 20 GOALS #5 (MJ7 Ft. Noori) | 4K - Invidious

1 Like

Sorry for the late reply… Yes I do have rpm fusion enabled.

The other video is also choppy with flatpak but doesn’t play at all in the official version. Where the video would play it tells me: “No compatible source was found for this media”.