Character issues with Tor Browser 11.0.1 on Fedora 35 XFCE4

Running Tor Browser version 11.0.1 on Fedora 35 XFCE Workstation is yielding broken characters in the menus and other places for me.

Screenshot of the issue:

This was working fine for me on a previous version of Tor Browser (10) on this XFCE env. in Fedora 34, fwiw. I am also running this as non-root.

I tried downloading a fresh version of Tor Browser and when I do the initial launch the same issue occurs. I am wondering if this is an issue on XFCE environments in particular due to some strange encoding irregularity.

Here are some system details I am running with:

OS: Fedora
Kernel: x86_64 Linux 5.14.17-301.fc35.x86_64
DE: Xfce4
WM: Xfwm4
WM Theme: Default
Font: Sans 10
CPU: Intel Core i5-2520 @ 4x 3.2GHz
GPU: Mesa Intel(R) HD Graphics 3000

Hi, it’s a know issue: Fonts don't render (#40382) · Issues · The Tor Project / Applications / tor-browser-build · GitLab

Try this workaround.

Ah, I missed that - thank you @gus .


I came here to report the same bug (on Fedora 33 and 34)

Thanks for the links, I’ll try the workaround

Hi, it’s a know issue, will be solved in some versions later.

Hi, I’m sure it will, but when?
For now, I’m happy as I applied the workaround (so easy) and have the fonts

This issue is easy to solve but without font, I consider it as a main issue : I am not expecting that new users will join the tor browser project (I don’t know how many will pause its usage).

############## the workaround pointed by [Maven Fonts don't render (#40382) · Issues · The Tor Project / Applications / tor-browser-build · GitLab)

In “fonts.conf”. On my system(Fedora 35) file’s path is “~/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/TorBrowser/Data/fontconfig/fonts.conf”

In first line: <?xml version="1.0"?>

Adding “1” to version number is fixing the issue: <?xml version="11.0"?>

Seems logical since problem occurred right after Tor Browser was updated to 11.0 version

Path on no install tor browser:

I just posted a question and instead I used your solution and my problem is solved. Thank you Leto