Email Regarding Updating obfs4proxy

Yesterday I’ve received an email from The sender requests me to update obfs4proxy at version 0.0.14. Is this a trustworthy request? And if so, what exactly are the steps I have to do in order to proceed the update?

Yes, update is needed.
Such request is also duplicated here on forum:

It depends on your OS. You need to replace old binary with new binary.
Sadly, I can’t say how to do this exactly.
Maybe other people will help.

If you use the Docker image it should work like this:

docker exec -it -u root CONTAINERNAME /bin/bash

In the container run

apt update && apt upgrade

After that the command

/usr/bin/obfs4proxy -version

should return


sudo apt -t bullseye-backports install obfs4proxy
made the trick. Now is 0.0.14 running.

I got two errors:

E: Sperrdatei /var/lib/dpkg/lock-frontend konnte nicht geöffnet werden. - open (13: Keine Berechtigung)
E: Erlangen der Sperre für die Dpkg-Oberfläche (/var/lib/dpkg/lock-frontend) nicht möglich; sind Sie root?


tells it remains on 0.0.13

What do I have to do?

If what I have written does not work

then try

sudo apt update && sudo apt upgrade

Does this apply to a Fedora bridge?

I can’t reply to the other thread (the one linked above) but the Ubuntu .deb from meskio worked for 2 of my 4 servers.

Of the two remaining servers:

1 is Ubuntu 20.04.5 (focal)
1 is Jammy but ARM instead of AMD

what can be done about these?

EDIT: I tried the .debs from the Debian repository on the two servers mentioned above and surprisingly they apparently worked okay

so now I have two servers (the Focal server and the ARM Jammy server) reporting “0.0.14-1~bpo11”, from the Debian repository, and two servers (both normal Jammy) reporting “0.0.14-1”, from mesiko’s link, and I’m not sure what the difference is. Maybe I should put the other two on the “0.0.14-1~bpo11” as well?